Monday, March 31, 2008

Creating your own custom Wireshark Dissector (CodeProject)

CodeProject: Creating your own custom Wireshark Dissector
This article describes how to create a Wireshark dissector as well as how to setup the Wireshark build environment
Download packet-amin_src.zip - 9.2 KB

Sunday, March 30, 2008

TSQL Regular Expression Workbench (simpe-talk)

TSQL Regular Expression Workbench (simple-talk)
This Workbench is about using Regular expressions with SQL Server via TSQL. It doesn't even attempt to teach how regular expressions work or how to pull them together. There are plenty of such resources on the Web. The aim is to demonstrate a few possibilities and try to persuade you to experiment with them if you don't already use Regex with SQL Server.

RegexWorkbench.sql
RegexWorkbench2000.sql
printer friendly version

xp_regex: Regular Expressions in SQL Server 2000 (CodeProject)

xp_regex: Regular Expressions in SQL Server 2000
This is a SQL Server 2000 Extended Stored Procedure writted in Managed C++. It allows you to use regular expressions in T-SQL.

Regular Expressions are probably the best tool for text parsing. Using Regular Expressions GREATLY simplifies anything for which you would normally use CHARINDEX, PATINDEX, SUBSTRING, STUFF, REPLACE, etc.
xp_regex is an Extended Stored Procedure for SQL Server 2000 written in Managed C++ that lets you use Regular Expressions from T-SQL. In case you’re skeptical about the performance when mixing non-.NET code (in this case SQL Server) and .NET code in the same process, don't be.

xp_regex_match
xp_regex_format
xp_regex_split
xp_regex_replace


Download source - 109 Kb

SQL 2000 DBA Toolkit:RegExp (SQL Server Central)

SQL 2000 DBA Toolkit Part 2 Part 1 (SQL Server Central)

Regular Expression Tools
Regular expressions (regex's) are a precise notation for approximate matching. One of the most popular styles of regular expression syntax is the Perl syntax. The regular expression tools in the toolkit use the Boost::Regex++ library, which is compliant with Perl syntax. NOTE: Microsoft's regular expression syntax differs somewhat from Perl syntax, so .NET-specific regular expressions might require tweaking to use with these tools.

sql function & procedures:
fn_regex_match (@searchexpression, @searchstring, @options)
xp_regex_search (@searchexpression, @searchstring, @options)
xp_regex_split @searchexpression, @searchstring, @options
fn_regex_replace (@searchexpression, @searchstring, @replacement, @options)

Download the DBA Toolkit Here

Friday, March 28, 2008

Google free proxy! - Access restricted web sites using Google language tools service as a proxy (Google Hacks)

Google free proxy! -Access restricted web sites using Google language tools service as a proxy. (Google Hacks)

http://www.google.com/translate?langpair=enen&u=www.forbiddensite.com

Browse restricted websites with Virtual-Browser (lifehacker)

Browse restricted websites with Virtual-Browser (lifehacker)
Virtual-Browser is a free and anonymous web-based proxy service.
Unlike other proxies, there is no software to install or complicated instructions to follow. Just enter a URL (website address) in the form above. Through Virtual-Browser, you can use websites but they cannot uniquely identify or track you. Virtual-Browser hides your real IP address and our encrypted connection (rotate 13/base 64) prevents monitoring of your network traffic.

Virtual-Browser

Diferior CMS - multi-purpose content management system

Diferior — CMS on steroids (different + superior, get it?) is a multi-purpose content management system, meaning that it provides all the necessary tools to easily publish and organize your content. What is so special about it, you ask? Well, this is not your ordinary blog CMS. In fact, it is capable of distributing files via BitTorrent, HTTP and FTP protocols, has inbuilt forums, a sophisticated user system and many many more features that each can be tweaked, customized or disabled altogether. You can run torrent trackers, blogs, forums and other community-based sites with it.

Encrypt your web browsing session (with an SSH SOCKS proxy) (lifehacker)

Encrypt your web browsing session (with an SSH SOCKS proxy) (lifehacker)

SSH server
read more: you can set one up at home with free software

Start your SSH tunnel
You've got access to an SSH server and you want to start using it as your proxy. To do so, you're going to set up a "tunnel" which passes web traffic from your local machine to the proxy over SSH. The command to do so is:
ssh -ND 9999 you@example.com

Set Firefox to use SOCKS proxy
Once your proxy's up and running, configure Firefox to use it. From Firefox's Tools menu, choose Options, and from the Advanced section choose the Network tab. Next to "Configure how Firefox connects to the Internet" hit the "Settings" button and enter the SOCKS information, which is the server name (localhost) and the port you used (in the example above, 9999.)


Vidalia 0.1.2 is released (Mar 24 2008)

Vidalia is a cross-platform controller GUI for Tor, built using the Qt framework. Using Vidalia, you can start and stop Tor, view the status of Tor at a glance, and monitor Tor's bandwidth usage. Vidalia also makes it easy to contribute to the Tor network by helping you set up and manage your own Tor relay.
download page

Multiply Your PC's Desktops with VirtuaWin (lifehacker)

Multiply Your PC's Desktops with VirtuaWin (lifehacker)
Free virtual desktop manager VirtuaWin creates multiple workspaces on your PC without bogging down your system. Like other virtual desktop utilities for Windows we've covered (Virtual Dimension, Vista Virtual Desktops, Dexpot) VirtuaWin provides hotkeys for switching desktops, custom features per desktop, and a configurable number of desktops (up to 160 20). VirtuaWin is also open source and describes itself as small and fast "with no unnecessary features." If you want extra features, you can still have them by installing VirtuaWin Modules, which enhance the app much like Firefox extensions. (How we love pluggable open source software!) VirtuaWin is a free download for Windows only.
VirtuaWin - Virtual Desktops for Windows [via Worker's Edge]

Protect Your Privacy When Downloading (lifehacker)

Protect Your Privacy When Downloading (lifehacker)


IP-blocking application PeerGuardian2 (PG2)

Mount USB Drives in Assigned Folders to Keep Them Straight (lifehacker)

Mount USB Drives in Assigned Folders to Keep Them Straight (lifehacker)


Assign USB Drives to a Folder [gHacks]

Cisco Press eBooks

Cisco Press eBooks

ReportGen for Cisco PIX/ASA

ReportGen for Cisco PIX/ASA
Log file parser and reporter for Cisco PIX firewall logs created by a Syslog Daemon like Kiwi Syslog Daemon

History:Version 1.1.9 ASA Compatability added

Download Now
Released: Tue, 24-Oct-2006
Version: 1.1.9
File Size: 2.86 MB
Home Page: RnR Software

Reliable Static Routing Backup Using Object Tracking (Cisco Systems)

Reliable Static Routing Backup Using Object Tracking (Cisco Systems)
The Reliable Static Routing Backup Using Object Tracking feature introduces the ability for the Cisco IOS software to use Internet Control Message Protocol (ICMP) pings to identify when a Point-to-Point over Ethernet (PPPoE) or IP Security Protocol (IPSec) Virtual Private Network (VPN) tunnel goes down, allowing the initiation of a backup connection from any alternative port. The Reliable Static Routing Backup Using Object Tracking feature is compatible with both preconfigured static routes and Dynamic Host Configuration Protocol (DHCP) configurations.

Reliable Static Routing Backup Using Object Tracking (pdf)

Configuring Reliable Static Routing Backup Using Object Tracking: Static Routing Examples
The following example configures the Reliable Static Routing Backup Using Object Tracking feature using static routing for a point-to-point primary gateway. The primary interface is a PPPoE Fast Ethernet interface, and the backup interface is a dialer interface. This example applies to Cisco IOS Release 12.3(14)T and later releases.
interface FastEthernet 0/0

description primary-link

ip address 10.1.1.1 255.0.0.0

interface Dialer 0

description backup-link

ip address 10.2.2.2 255.0.0.0

ip sla monitor 1

type echo protocol ipIcmpEcho 172.16.23.7

timeout 1000

frequency 3

threshold 2

ip sla monitor schedule 1 life forever start-time now

track 123 rtr 1 reachability

access list 101 permit icmp any host 172.16.23.7 echo

route map MY-LOCAL-POLICY permit 10

match ip address 101

set interface dialer 0 null 0

!

ip local policy route-map MY-LOCAL-POLICY

ip route 0.0.0.0 0.0.0.0 10.1.1.242 track 123

ip route 0.0.0.0 0.0.0.0 10.2.2.125 254

The following example configures the Reliable Static Routing Backup Using Object Tracking feature using static routing for a multipoint primary gateway. Both the primary interface and the backup interface are Ethernet interfaces. This example applies to Cisco IOS Release 12.3(14)T and later releases.
interface ethernet 0

description primary-link

ip address 10.1.1.1 255.0.0.0

interface ethernet 1

description backup-link

ip address 10.2.2.2 255.0.0.0

ip sla monitor 1

type echo protocol ipIcmpEcho 172.16.23.7

timeout 1000

frequency 3

threshold 2

ip sla monitor schedule 1 life forever start-time now

track 123 rtr 1 reachability

access list 101 permit icmp any host 172.16.23.7 echo

route map MY-LOCAL-POLICY permit 10

match ip address 101

set ip next-hop 10.1.1.242

set interface null 0

!

ip local policy route-map MY-LOCAL-POLICY

ip route 0.0.0.0 0.0.0.0 10.1.1.242 track 123

ip route 0.0.0.0 0.0.0.0 10.2.2.125 254

Verifying the State of the Tracked Object: Example
The following example displays information about track objects in the IP route track table:
Router# show ip route track-table

ip route 0.0.0.0 0.0.0.0 10.1.1.242 track-object 123 state is [up]

Tuesday, March 25, 2008

Secure BGP Template v5.2 (14 FEB 2008) released

http://www.cymru.com/Documents/secure-bgp-template.html

read more ...

TCP/IP and NBT configuration parameters for Windows XP (Microsoft)

TCP/IP and NBT configuration parameters for Windows XP (Microsoft)
This article defines all the registry parameters that are used to configure the protocol driver, Tcpip.sys. Tcpip.sys implements the standard TCP/IP network protocols. The TCP/IP protocol suite implementation for Windows XP reads all its configuration data from the registry. This information is written to the registry by the Network tool in Control Panel as part of the Setup process. Some of this information is also supplied by the Dynamic Host Configuration Protocol (DHCP) Client service if the DHCP Client service is enabled.The implementation of the protocol suite should perform correctly and efficiently in most environments by using only the configuration information that is gathered by DHCP and by the Network tool in Control Panel. Optimal default values for all other configurable aspects of the protocols have been encoded in the drivers. There may be some unusual circumstances in customer installations where changes to certain default values are appropriate. To handle these cases, optional registry parameters can be created to modify the default behavior of some parts of the protocol drivers.Caution The Windows XP TCP/IP implementation is largely self-tuning. Adjusting registry parameters without careful study may reduce your computer's performance.


read the whole microsoft support article ...

Friday, March 21, 2008

Automated Diagnostics for Commercial Networks (Cisco Systems)

Automated Diagnostics for Commercial Networks (Cisco Systems)
The following list contains simple, easy-to-use scripts and applets that allow network engineers managing Commercial networks to automate common diagnostics and customize complex network tasks.
The scripts and applets use Cisco IOS Embedded Event Manager (EEM), a powerful device and system management technology integrated into specific Cisco switches and routers. EEM helps customers harness the network intelligence intrinsic to Cisco IOS Software and gives them the ability to customize behavior based on network events as they happen.


read more, download scripts

Filtered Index Design Guidelines (MSDN, SQL Server 2008)

Filtered Index Design Guidelines (SQL Server 2008, MSDN)

A filtered index is an optimized nonclustered index, especially suited to cover queries that select from a well-defined subset of data. It uses a filter predicate to index a portion of rows in the table. A well-designed filtered index can improve query performance, reduce index maintenance costs, and reduce index storage costs compared with full-table indexes.

Filtered indexes can provide the following advantages over full-table indexes:

  • Improved query performance and plan quality
    A well-designed filtered index improves query performance and execution plan quality because it is smaller than a full-table nonclustered index and has filtered statistics. The filtered statistics are more accurate than full-table statistics because they cover only the rows in the filtered index.
  • Reduced index maintenance costs
    An index is maintained only when data manipulation language (DML) statements affect the data in the index. A filtered index reduces index maintenance costs compared with a full-table nonclustered index because it is smaller and is only maintained when the data in the index is affected. It is possible to have a large number of filtered indexes, especially when they contain data that is affected infrequently. Similarly, if a filtered index contains only the frequently affected data, the smaller size of the index reduces the cost of updating the statistics.
  • Reduced index storage costs
    Creating a filtered index can reduce disk storage for nonclustered indexes when a full-table index is not necessary. You can replace a full-table nonclustered index with multiple filtered indexes without significantly increasing the storage requirements.

Getting the list of columns for a table

SELECT TOP 1
STUFF((SELECT ‘, ‘ + T2.COLUMN_NAME FROM INFORMATION_SCHEMA.COLUMNS AS T2 WHERE T2.TABLE_NAME = T1.TABLE_NAME FOR XML PATH (”)), 1, 2,”) AS COL_NAMES
FROM INFORMATION_SCHEMA.COLUMNS AS T1
WHERE T1.TABLE_NAME = ‘CONCISE_DATA’
ORDER BY T1.ORDINAL_POSITION

Getting the list of columns for a table

Wednesday, March 5, 2008

ZipTie - a framework for Network Inventory and Configuration Management

ZipTie is a framework for Network Inventory and Configuration Management. ZipTie allows you to discover all devices in your network to create a comprehensive inventory and to manage the configuration of those devices. Every installation includes a suite of tools to help manage your network. In addition, ZipTie is constantly under development and leverages a large community of network experts who share their tools, device adapters, and experience. It allows you to create or import your own custom tools or download them from the ZipTie community. The software is free to download, use, and distribute. ZipTie.org is the community site and tools exchange for Open Network Inventory and Configuration Management.
To view/download ZipTie's datasheet, click here.

ZipTie features:
Discovery, backup and restoration of network device configurations
Comparison of network device configurations across devices and over time
Detection of configuration changes
Distribution of single- and multi-device configuration changes
Organized, extensible set of tools for performing administration tasks to any network device
Single, common ‘language’ for controlling the configuration of any network device, regardless of manufacturer

YouTube Hijacking: A RIPE NCC RIS case study

YouTube Hijacking: A RIPE NCC RIS case study (RIPE NCC)
On Sunday, 24 February 2008, Pakistan Telecom (AS17557) started an unauthorised announcement of the prefix 208.65.153.0/24. One of Pakistan Telecom's upstream providers, PCCW Global (AS3491) forwarded this announcement to the rest of the Internet, which resulted in the hijacking of YouTube traffic on a global scale.

BGP DoS
http://blog.rootshell.be/2008/02/28/bgp-dos/

BGP Techniques for Internet Service Providers

BGP Techniques for Internet Service Providers Jun'06
philip-smith.pdf

Understanding BGP Session Failures in a Large ISP
infocom07-sessionfailure.pdf

BGP Link Bandwidth (Cisco Systems)

BGP Link Bandwidth (Cisco Systems)
The Border Gateway Protocol (BGP) Link Bandwidth feature is used to advertise the bandwidth of an autonomous system exit link as an extended community. This feature is configured for links between directly connected external BGP (eBGP) neighbors. The link bandwidth extended community attribute is propagated to iBGP peers when extended community exchange is enabled. This feature is used with BGP multipath features to configure load balancing over links with unequal bandwidth.

BGP Best Path Selection Algorithm (Cisco Systems)

BGP Best Path Selection Algorithm (Cisco Systems)
Border Gateway Protocol (BGP) routers typically receive multiple paths to the same destination. The BGP best path algorithm decides which is the best path to install in the IP routing table and to use for traffic forwarding.

Border Gateway Protocol (BGP) - Cisco Systems

Border Gateway Protocol (BGP) - Cisco Systems
BGP performs interdomain routing in Transmission-Control Protocol/Internet Protocol (TCP/IP) networks. BGP is an exterior gateway protocol (EGP), which means that it performs routing between multiple autonomous systems or domains and exchanges routing and reachability information with other BGP systems....

BGP Features Roadmap (Cisco Systems)

BGP Features Roadmap (Cisco Systems)
This roadmap lists the features documented in the Cisco BGP Implementation Configuration Guide and maps them to the modules in which they appear....

BGP Features Roadmap (pdf)
Cisco IOS IP Routing Protocols Configuration Guide, Release 12.4 (PDF - 12 MB)

BGP Configuration Using Peer Templates (Cisco Systems)

BGP Configuration Using Peer Templates (Cisco Systems)
The BGP Configuration Using Peer Templates feature introduces a new mechanism that groups distinct neighbor configurations for Border Gateway Protocol (BGP) neighbors that share common policies. This type of policy configuration has been traditionally configured with BGP peer groups. However, peer groups have certain limitations because peer group configuration is bound to update grouping and specific session characteristics. Configuration templates provide an alternative to peer group configuration and overcome some of the limitations of peer groups.

BGP Support for Fast Peering Session Deactivation (Cisco Systems)

BGP Support for Fast Peering Session Deactivation (Cisco Systems)
The BGP Support for Fast Peering Session Deactivation feature introduces an event driven notification system that allows a Border Gateway Protocol (BGP) process to monitor BGP peering sessions on a per-neighbor basis. This feature improves the response time of BGP to adjacency changes by allowing BGP to detect an adjacency change and deactivate the terminated session in between standard BGP scanning intervals. Enabling this feature improves overall BGP convergence.

Setting a Preferred Route by Influencing EIGRP Metrics (Cisco Systems)

Setting a Preferred Route by Influencing EIGRP Metrics (Cisco Systems)
This document describes how to create a preferred route by influencing Enhanced Interior Gateway Routing Protocol (EIGRP) metrics. Given the topology shown in the network diagram, this document describes several ways to influence IP traffic from the clients to the servers so that the path R1>R2>R3 is preferred. The goal is to make the path R1>R2>R4 into a backup that is only used in the event of a failure at R3.

How Does Load Balancing Work? (Cisco Systems)

How Does Load Balancing Work? - Cisco Systems
Load balancing is a standard functionality of the Cisco IOS router software, and is available across all router platforms. It is inherent to the forwarding process in the router and is automatically activated if the routing table has multiple paths to a destination. It is based on standard routing protocols, such as Routing Information Protocol (RIP), RIPv2, Enhanced Interior Gateway Routing Protocol (EIGRP), Open Shortest Path First (OSPF), and Interior Gateway Routing Protocol (IGRP), or derived from statically configured routes and packet forwarding mechanisms. It allows a router to use multiple paths to a destination when forwarding packets...

Load Sharing with BGP in Single and Multihomed Environments: Sample Configurations (Cisco Systems)

Load Sharing with BGP in Single and Multihomed Environments (Cisco Systems)
Load sharing allows a router to distribute the outgoing and incoming traffic among multiple paths. The paths are derived either statically or with dynamic protocols, such as:

- Routing Information Protocol (RIP)
-Enhanced Interior Gateway Routing Protocol (EIGRP)
- Open Shortest Path First (OSPF) Protocol
- Interior Gateway Routing Protocol (IGRP)

By default, Border Gateway Protocol (BGP) selects only a single best path and does not perform load balancing. This document shows how to perform load sharing in different scenarios with the use of BGP. For additional information about load balancing, refer to How Does Load Balancing Work?.

pdf